Are you ready for the webcast?
A short test is being performed now to check your computer's ability to display the virtual event you are about to attend.
For further information about system requirements and troubleshooting, please refer to our FAQ below.
Device Operating System Requirements:
  • Windows: Vista or later
  • OSX: 10.7 or later
  • IOS: 4.0 or later
  • Android: 4.0 or later (live is not supported)
  • Windows RT: 8 or later
  • Windows Phone: 8 or later (live is not supported)
  • Linux: Unsupported, but with proper configuration it can work
Internet Connection Requirements:
  • Broadband/Dedicated Internet Connection of 1Mbps or better
  • To test your connection speed please visit Speed Test
Browser Requirements:
  • Internet Explorer: 8.0 or later (11 highly recommended)
  • Chrome: 30 or later (most recent version highly recommended)
  • FireFox: 30 or later (most recent version highly recommended)
  • Safari: 6 or later (most recent version highly recommended)
  • Others: Unsupported, but with proper configuration it can work
  • For more information about upgrading your browser please visit Update Your Browser
Flash Requirements:
  • Windows and OSX: Flash 10 or later
  • Linux: Unsupported, but requires Flash 10 or later
  • To install or upgrade Flash, please visit Adobe Flash Player
Javascript Requirements:
  • Your browser must have Javascript enabled for the webcast to play. Please visit Enable Javascript to learn how to enable Javascript in your browser
Session Cookies Requirements:
  • Your browser must have Session Cookies enabled for the webcast to play. Please refer to your browser's help for information on how to enable cookies.